Jump to content


Photo

Tidloc's Header


  • Please log in to reply
31 replies to this topic

#1 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 21 February 2012 - 05:11 AM

Tidloc's Header v.2.60
by Tidloc


Introduction
I've decided to use this header instead of implementing everything inside my scripts as I first encountered the error of the stack going to deep by aliasing...
It's used by most of my script for saving/loading different additional things in save games or use old windows (with which i'm very much more experienced then the new ones)

Features

  • It's simply the header of my other scripts ;-)
  • you may alter the count of accessiores your actors can equip.
  • you can add other item-categories
  • all items (consumables, weapons armors and skills) can have scriptcalls in their notetags as on-use-effect
  • for all my script: no known compatibility issues, if you encounter any, please post them, most are bypassed by listing my scripts beneath the others and disable the unwanted features by the switches as stated. Nearly all is aliased or at least disable-able :D
    of course this is not valid for scripts that may have the same alteration, like another single-item-script...

Screenshot
no need?

How to Use
paste it of course above main, below all standart-scripts, but also above all of my scripts!
Detailed description on how to use this script in the first commented lines of the script
For altering the count of Accessoires, change the constant Accessoire_Count in the module Tidloc. Standard value is 1
For adding additional Item-Categories, change Item_Categories to = true. Below you can change the Names of your Categories., you are also allowed to have more then this three categories used by me, simple seperate them with comas. To assign an item to a specific category, write into its description either of the commands:



\class<*ID*>
\c<*ID*>
<c=*ID*>

, where *ID* is an integer equal one or greater.

Demo
Demo for the available tags, classification of items and my item scripts.

Script
Download this file.
If you want my independent ingame clock:

Spoiler


FAQ
Q: How do I add quests to the questlog?
A: please see the document also listed for downloading.

Q: Is there a way to get rid of "Manuals, Resources, Runes" from the menu because I don't use them at all.
A: set the constant Item_Categories to false.

Q: How do I set a certain category to an item as they are used in this script?
A: use a notetag and write

\c<ID>

in a single line. replace ID with the actual ID (from 1 increasing)

Credits and Thanks
- Tidloc

Links to my finished scripts here
    Questlog
    Alchemy Script
    Item Dismantling
    Dynamic Shop System
    Popup Message Windows
    Compass script
    Auction System

    Custom Equipment
      Diablo Equipment (Equipment Script enhancement)
      Socketed Equipment (Equipment Script enhancement)
Download only:
HTML Interpreter

I'm always open to suggestions or ideas, so feel free to contact me or write an answer =))

Edits:
02/21/2012: Questlog added
02/22/2012: Alchemy Script added and fixed one little bug thx to Non Ya xD
02/28/2012: Dismantling and Dynamic Shop added
03/03/2012: added the possibility to change scripts into spanish. Vocabulary already entered in Questlog
04/07/2012: some minor bugs fixed, reprogrammed some parts into better symantic and enabled calling some scripts over the main menu or by Key.
04/18/2012: some bugs fixed, now everything should work fine! =))
05/06/2012: added the popup message script and a major update to the header to version 1.5 (some bugs and some alteration for existing and future scripts made.
05/25/2012: added the compass script
05/27/2012: added the auction system and updated most of my scripts
06/02/2012: new release out! completely rewrote some parts of all scripts, especially the vocabulary party to supply multi-language games. If you update this header, all of my other scripts(if older then this point of time) also need to be updated. Also each script has now five additional constants:
02/05/2014: added the language script, resolved some minor bugs and smoothed some parts.
02/13/2014: added Custom Equipment and Diablo Equipment
02/16/2014: added socketed equipment and a big update to support commands throughout my scripts (welcoming any special suggestions on this part! ^^
02/17/2014: added the possibility to have scriptcalls directly in the notetags of items/Equipments/skill for an effect if you use them (Tagged Equipment now is also use-able in fights and in the item menu)
02/20/2014: added HP cost and Max-HP-% cost adjustable for skills and improved display of item categories
02/22/2014: added an independent ingame clock as addition and updated some parts, so my dynamic shop becomes compatible with my custom equips
02/26/2014: fixed a bug the yanfly battle engine induced in my scripts
03/02/2014: HTML now supports data in Rect as positioning and textwrap implemented.

08/30/2014: Added code for my custom items to be able to level and for my rune script


Edited by Tidloc, 30 August 2014 - 11:47 AM.


#2 Draqun

Draqun

    Newbie

  • Ace Member
  • 1 posts

Posted 09 April 2012 - 09:26 AM

I may be an idiot but when i start the game i get this error:

undefined method 'set_battle_system' for #<Game_System:0x7734f18>

What am I doing wrong?

#3 Facinus

Facinus

    Newbie

  • Ace Member
  • 3 posts

Posted 16 April 2012 - 09:43 AM

Aweome script, yet I have a small problem with it. I can load from the menu but not from the title screen.

(Genauer gesagt: Wenn ich Continue im Titelmenü auswähle, werden mir die Savestates angezeigt, aber wen ich mit Enter bestätigen möchte passiert nichts. Das Laden im Menü funktioniert jedoch ohne Probleme. Habe das Script in einem neuen Project probiert und hatte selbiges Problem.)

#4 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 18 April 2012 - 11:45 AM

@Draqun: I also figured this issue and was solved the day you posted it... xD
@Facinus: Thanks for the bugreport, now it's solved and working! ^__^

#5 Isaac Henby

Isaac Henby

    Abimon Master

  • Ace Member
  • 12 posts
  • LocationAtlantis
  • RM Skill - Designer

Posted 27 April 2012 - 09:59 PM

Do we need this script to operate your other scripts?

#6 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 28 April 2012 - 04:11 PM

yup, most of them, but in each script where it is required, it's state clearly, that it is so ;)

#7 Abysinian

Abysinian

    Member

  • Ace Member
  • 10 posts

Posted 02 June 2012 - 02:14 AM

Hey there,

Is there a way to get rid of "Manuals, Resources, Runes" from the menu because I don't use them at all.

Cheers.


Figured it out, nevermind :)

Edited by Abysinian, 02 June 2012 - 02:19 AM.


#8 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 02 June 2012 - 02:26 AM

lol, ok. also updated the FAQ now ^^

#9 Andynator

Andynator

    Newbie

  • Ace Member
  • 4 posts

Posted 07 June 2012 - 09:02 AM

Hello

I wanted to use this script in my project with http://www.rpgmakerv...alchemy-script/

I installed the header first, and under the header the alchemy script. But every time, i start the game, i get the message:


Script 'tidloc_header' line 595: No MethodError occured.
undefined method 'load_alch_data' for Tidloc_Alch:Class

A compatibility issue is out of the question, because this problem occures even with an new, empty project.

Is there any way to fix ist?

#10 More Cowbell

More Cowbell

    I am The Human Flamethrower. Woooo!

  • Ace Member
  • 362 posts
  • LocationCaerdydd, Cymru
  • RM Skill - Jack of All Trades

Posted 12 June 2012 - 06:12 AM

Well, for some reason the laptop I am using can't open .rb files. I don't suppose you could up this as .txt by any chance?

EDIT: Actually it's okay. I got the script from the Demo for your Questlog script. Cheers! x :)

Edited by Paddy, 12 June 2012 - 06:23 AM.

| MY SPRITES! cookiemonster.gifMY GFX! |

 

DeadpoolSig-Poe.jpg

 

Deadpoolgif-Poe.gif


#11 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 12 June 2012 - 03:27 PM

well, in the demo it's hardly the actual version of the scripts...
how to open .rb-files, three ways(if one isn't possible on your PC go to the next)
1. have notepad++ or any other scripting/compiling/intepreting editor
2. right-click file, select edit
3. right-click file, select open with, choose editor or notepad

#12 Andynator

Andynator

    Newbie

  • Ace Member
  • 4 posts

Posted 13 June 2012 - 05:10 AM

Really Nobody, who has a clue to my problem?

I download the demo from http://www.rpgmakerv...alchemy-script/ to test it again and again. But the game crashes instantly, if i try to start the demo as a game, or a test game... obviously i'm the only one, with this problem, but it seems impossible to me, make the script work.

Test the Demo? Crash.
Test with my Game-Project? Crash
Test with an Empty Project? Crash
Test as Administrator? Crash

... Where is my Mistake? Why forces the header my RPG-Maker to crash, every Time i install the Alchemy-Script? The Failur Message is either

Script 'tidloc_header' line 595: No MethodError occured.
undefined method 'load_alch_data' for Tidloc_Alch:Class

in my game. Or

Script 'tidloc's_Alchemy' line 677: SyntaxError occured.
unexpected keyword_end, expecting $end

in the demo.

Edited by Andynator, 13 June 2012 - 05:19 AM.


#13 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 13 June 2012 - 07:14 AM

@Andynator
err... first you could take a look into your PMs... (wrote you like over a week ago!)
or here in short:
did you download the most recent versions of my scripts?
I'm using these scripts without any problems...
Regarding the demo: updated the link, but somehow it only updated the visual part, not the link itself too... corrected that please try again (demo-link was way outdated)
but if you intend to use my scripts, I recommend to download the most actual versions (the .rb-files in the corresponding threads)

#14 Megumi

Megumi

    Newbie

  • Ace Member
  • 6 posts
  • RM Skill - Artist

Posted 02 July 2012 - 03:34 PM

Hello there. I am attempting to use your header in conjunction with your alchemy script. I have not modded the scripts in any way but simply placed them as is within the script editor. When I run a playtest of my game I keep getting this error: "unable to find file: data idloc.ini"

I am a complete newbie to all of this so I have no idea what that means. My apologies.

Edited by zogoto3000, 02 July 2012 - 03:37 PM.


#15 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 03 July 2012 - 09:13 AM

I'm quite sure it said tidloc.ini, the point is you need a file called tidloc.ini in your data-folder, as described in the thread of my alchemy script. if you follow the steps there, you will get it running in no time, but you have to write all the recipes by yourself in that file ;)

#16 Megumi

Megumi

    Newbie

  • Ace Member
  • 6 posts
  • RM Skill - Artist

Posted 05 July 2012 - 06:00 PM

Thanks you so much Sir Tidloc ^_^ I am very appreciative of your help. I've got the script running smoothly with my game now.

#17 Konora

Konora

    Princess Inteliel

  • Ace Member
  • 28 posts
  • LocationOrlando, FL
  • RM Skill - Designer

Posted 05 August 2012 - 06:28 PM

Hmm, regarding the "Manuals, Resources, Runes" thing...what are they for? Because I want to use them, but I don't know how. Unless they're useless and there for nothing.

-Princess Inteliel Konora-

Amateur scripter, intermediate eventer,

 

My patron troll is Nepeta :33

Ve~ I'm Italy's sorella.

 

Things I support:

Spoiler

 

Current Project:

Spoiler

#18 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 09 August 2012 - 08:49 AM

these additional item classes can be used be setting the notetag
class<*id*>
for the items. (not working with weapons or armors)

where 1 is the the first additional category, 2 is the second,....
if you want to keep the item in the normal item-view, then leave this notetag out :)

Edit: also updated the How To above to line that out! ;)

Edited by Tidloc, 09 August 2012 - 08:51 AM.


#19 Bunni89

Bunni89

    eyebrows to challenge the heavens

  • Ace Member
  • 770 posts
  • LocationCardiff, Wales
  • RM Skill - Artist

Posted 11 August 2012 - 09:52 AM

Hi, just made an account to ask this and I'm a complete newbie so forgive me if it's really obvious XD
I just installed the Header and haven't changed it at all. It works but as soon as I try to access the Weapons menu in my game it crashes and gives this error:
Script 'Tidloc Header' line 1030: NameError occured.
uninitialized constant Window_ItemList_2::Game_CustomEquip
I have no other scripts installed but your message window one and your quest system. I'm not sure if it might be affecting things but I'd created a new weapon type before adding this script called 'Hair Ornaments' and set one character to start off with them equipped. (Don't ask. The guy fights by flicking his hair at people XD) But I also made new classes and new armor types and no errors there...
EDIT: Actually upon double-checking it gives the error for armor as well. I think it must be my custom types that's the problem, I just can't figure out how I'm meant to make the script recognise them. God, I'm useless! XD
EDIT: Okay now I don't even know what was wrong but I seemed to fix it by changing:
when :weapon
item.is_a?(RPG::Weapon) || (item.is_a?(Game_CustomObject) && item.object.is_a?(RPG::Weapon))
to
when :weapon
item.is_a?(RPG::Weapon) || (item.is_a?(RPG::Weapon) && item.object.is_a?(RPG::Weapon))
Looks very repetitive now but works just like it did before inserting the header. I am officially baffled.

P.S: Thank you so much for the Questlog script! Just wondering- is there any way to change the description scroll keys? (pageUp and pageDown by default, I wanted to perhaps change it to the up and down on the num pad) I found it a little unintuitive and would never have guessed what to press if it weren't for the demo.
I'm attempting to repurpose this into an info encyclopedia so there's gonna be a lot of scrolling. By the way, the external loading add-on is really awesome! Much easier for a confused noob :3

Edited by Bunni89, 11 August 2012 - 10:11 AM.

.:: PERPETUAL NEWBIE ::.
...Like a million ideas but for now I need to practise...
My deviantART account: bunni89.deviantart.com

I support:
zombie_game_support_bar_by_jonath4nc-d7p


#20 Tidloc

Tidloc

    Tidloc

  • Ace Member
  • 110 posts
  • LocationVienna, Austria
  • RM Skill - Coder

Posted 12 August 2012 - 05:42 AM

thanks for your interest in my scripts ^^

yes, this lines are for a script I work for and I know that issue... this (let's call it a) beta-version of my header shouldn't be up, at some time I copied it and the old one is now unfortunately gone.

Yes, there is a way, but only if you got some kind of keyboard-script too, because by default these keys are not sampled by RGSS. (I made it this way, so it can be used by nearly everyone xD )
And that's what the demo is for: to show the functionality ;P
fyi, these keys are defined in lines 795 and 797 ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users